Patch notes can be found in the new forums here.

ComicPress 2.9.4 is the update to the theme that corresponds to making it compatible with WordPress 3.4

– Note: I have made the things that are specific to WP 3.4 backwards compatible with older versions of WP at least 3.1 and above.

If you want to check out the full DIFF of changes from 2.9.3.1 to 2.9.4

- Phil